PDA

View Full Version : Uke Belcat pickup - advice please



paulfreeland
02-05-2016, 03:37 AM
Hi,

I have fitted a Belcat UK 500T pickup to my baritone ukulele.

Unfortunately, it's clipping/distorting a bit even when played quietly. I' guessing that the output is a bit higher than the preamp is expecting because it's a baritone rather than a soprano uke.

Any ideas what I should do? Can I attenuate the signal with a resistor somehow?

Cheers

Paul

PhilUSAFRet
02-05-2016, 05:12 AM
Make sure you set your amp on flat, medium low volume, dial in the preamp on medium or lower volume to get the tone(s) you want from your uke, then go with the amp's settings from there on. If you are still getting some clipping/distortion, or if the amp volume isn't giving you the volume you want, adjust the pre-amp volume a little at a time, up or down, and see if that will take care of it. There are others here who can give you a more technical explanation.

deschutestrout
02-05-2016, 05:17 AM
This may sound dumb, but have you tried replacing the batteries? Active pickups sound like crap when the battery starts to fade.

paulfreeland
02-06-2016, 06:32 AM
Thanks for helping - yes, unfortunately the clipping happens even when the controls on the preamp are all right down. This is why I'm thinking I need to somehow drop the input level before it hits the preamp.

paulfreeland
02-06-2016, 06:33 AM
Good shout - Yes, I have tested the batteries and they're full up.

paulfreeland
02-07-2016, 05:27 AM
Any other ideas folks?