PDA

View Full Version : Is the UU site have a virus? check this out



MGM
11-27-2011, 04:40 PM
I just opened the home page and the titles are upside down backwards. Then i just posted a note about Ponos and it said i was Is this uke legit???? Is it just me going bonkers or do others see this MGM

mds725
11-27-2011, 05:00 PM
Mike, I've gotten the same unusual display of the UU home page on and off for the past few weeks, although not tonight. At first, I thought it was the UU mods having fun, and then I thought it was my computer, but I guess it's something else. So far, though (*knocks wood*), my username hasn't changed.

http://www.ukuleleunderground.com/forum/attachment.php?attachmentid=30366&d=1322452641

philpot
11-27-2011, 05:02 PM
Nothing on my end.

Kanaka916
11-27-2011, 05:04 PM
Sorry guys, It's not the Mods. All we have access to is the Forum pages. I would send an email to admin and hopefully they'll be able to figure it out.

bluesuke
11-27-2011, 05:12 PM
It all looks good from my end. Are you guys running a pc or a mac Im on a mac and it looks fine

Gmoney
11-27-2011, 05:24 PM
It all looks good from my end. Are you guys running a pc or a mac Im on a mac and it looks fine

It actually is a bug in the CSS code that UU uses for the font display in those frames. I've researched it a bit & even got an IE developer to look at it (disclosure: I work for Microsoft). I'll dig up his reply and add it to the thread with the details for the UU staff to address. Since I hardly ever go to the main UU page, I don't see it enough to be annoying, so didn't already follow up w/the staff.

The following is what I received from the IE developer; though I have no idea what it all means - I'm not a coder!


I poked around and theyíre creating that text as a VML shape in typeface-0.14.js.

In typeface-0.14.js theyíre doing this check to determine whether to use canvas or VML for the text in question:

var backend = !!(window.attachEvent && !window.opera) ? 'vml' : window.CanvasRenderingContext2D || document.createElement('canvas').getContext ? 'canvas' : null;

Since IE9 is returning a function for window.attachEvent, itís using VML as the rendering backend instead of canvas. Really they should be doing the check in the middle (for canvas features) first, Iíd thinkÖ

Anyway, the VML rendering path for the page has this suspect line when creating text: shape.style.flip = 'y';
This line seems to have no effect in IE9. I canít speak to why because Iím not too familiar with VML, but itís why the text is upside-down.

I suspect this is related: http://msdn.microsoft.com/en-us/library/gg622932(v=VS.85).aspx

The solution would probably be to reach out to them about using canvas for their text rendering solution in IE9, or to add a meta tag to force IE8 mode. I tinkered around with Fiddler a bit to coax the page into using canvas and it works fine that way.

Hope this makes sense to the UU staff!

Dan Uke
11-27-2011, 05:24 PM
I have Windows 7 and I have the same problem.

Gadzukes!
11-27-2011, 05:26 PM
What browser are you guys using? I'm gonna guess IE.

Nickie
11-27-2011, 05:35 PM
I'm using Mozilla Foxfire. I have 2 PCs. They both got knocked for a loop by some bug. My geek fixed it, said it was really unusual, and probably came from a forum .... since this is the one I visit way more than any others, I'm supsicious. My work laptop, which runs a very tight, very complicated anti virus wasn't affected. He said that sometimes we get tricked into opening something, and there it is... the virus.

joejeweler
11-27-2011, 05:45 PM
I've noticed this on my computer for months now,....just figured because i wasn't allowed access to that side it was blocking the home page.

BTW,....i get a similar upside reverse type when i visit the Kamoa ukuleles website. Interestly, their homepage is reading OK, but when i click onto their Ukulele or Case links they show up unreadable, but pics are there.

I have windows 7 and use IE mostly.

haolejohn
11-27-2011, 05:48 PM
It actually is a bug in the CSS code that UU uses for the font display in those frames. I've researched it a bit & even got an IE developer to look at it (disclosure: I work for Microsoft). I'll dig up his reply and add it to the thread with the details for the UU staff to address. Since I hardly ever go to the main UU page, I don't see it enough to be annoying, so didn't already follow up w/the staff.

I'll go with this...I know Glenn. He is an honest guy. He wouldn't lie to us:)

haolejohn
11-27-2011, 05:50 PM
I'm using Mozilla Foxfire. I have 2 PCs. They both got knocked for a loop by some bug. My geek fixed it, said it was really unusual, and probably came from a forum .... since this is the one I visit way more than any others, I'm supsicious. My work laptop, which runs a very tight, very complicated anti virus wasn't affected. He said that sometimes we get tricked into opening something, and there it is... the virus.

This is the only forum I visit. As a matter of fact it is one of only 5 websites I visit with any regularity. I think it is safe. Been here for over 3 years. But then again I open nothing suspicious or from unknown sources (including those Nigerian princess scams:))

Please let us know if you find out where the bug comes from.

Kanaka916
11-27-2011, 05:56 PM
I'm here on a daily basis and have not encountered any problems. I rarely start on the main page. BTW, still using Vista as the OS and FF as my browser.

haolejohn
11-27-2011, 05:58 PM
I'm here on a daily basis and have not encountered any problems. I rarely start on the main page. BTW, still using Vista as the OS and FF as my browser.

I agree. I have the forums set up as my homepage and I always have it up at work as well, but no can post there. gotta keep kids busy not Mr. Eller:)

Doc_J
11-27-2011, 05:58 PM
I've stopped using IE, and switched to FireFox and Safari, to fix a few technical problems at other sites.
No UU problems on FireFox and Safari.

MGM
11-27-2011, 07:01 PM
Well I'm relieved it's not just me. I thought my ammonia levels were going up and I was hallucinating again or Reached their thailand version..lol. Still can't figure out how i got logged in as someone else though. My apologies to my uke is legit on his name appearing as the poster of the Pono thread.

kaizersoza
11-27-2011, 09:35 PM
my homepage been like it for a few months now, it does'nt seem to do any harm as long as you can read backwards

drbekken
11-27-2011, 09:42 PM
My computer, a pre-historic Toshiba, also has the letters twisted around.

mm stan
11-27-2011, 10:19 PM
All I notice about mine is when I go to the main page it went to the about section..it started yesterday for several times....but not seems to be workig fine..using IE
windows 7 ....but I got a bug on my facebook..with my chat box, it display my chat messages...anyone have that problem...and nobody at facebook to contact...goes to
the report problem Rodrigo..but unable to type problem in...it says he is in too..green dot..how do you get in touch with facebook otherwise..

ukuhippo
11-27-2011, 10:56 PM
Problems like these mostly have two optional causes:

1. A Virus/malware (very unllikely, as most of us seem to have no problems)

2. Browserproblems (it hardly ever is the OS that's to blame, though it could be a certain browser on a certain OS)

Regarding 2:
- IE has been cleaning its act up in the past few years, but has been known for its faulty interpretation of CSS-code. Anyone with a version below IE 9: please update to that version, it's been around since March this year, and it fixes a couple of CSS-rendering problems. If you're not able to upgrade due to whatever reason: bad luck.
Another option is to switch to a decent (my personal feelings) browser like Firefox, Opera or Chrome, there are choices out there. And I am totally talinking Windows here, I have no clue how Macs work.


edit: one more thing, if your browser window looks anything like this:

30367

please re-install Windows.

wolfybau
11-27-2011, 11:10 PM
my homepage been like it for a few months now, it does'nt seem to do any harm as long as you can read backwards

lol Ive encountered it for mounth now but only on my drummers comp, and thats basicaly my attictude snce I am dyslexic and used to dealing with things backwords haha

but on my computer and laptop it doent do it. the differnec seems sto be that mine are windows XP and his is Windows 7, my bassist has vista and had no problems, as Im reading this thread ,it seems that everyone havign a prob is running 7 ...... a connection there??

note - we are using the same browser version...

ukuleledaveey
11-28-2011, 12:05 AM
:) i thought it was designed that way, some groovy backwards russian thing lol. so i guess it is playin up on my computer to, i am running windows 7, changed last week to chrome and my main hotmqail account got hacked, but that could be just coincidence, but i never had a problem with the tittle i just go straght to the index page going to to have a look now im on chrome but think they are still the wrong way round :)

ukulefty
11-28-2011, 09:03 PM
:) i thought it was designed that way, some groovy backwards russian thing lol.


Me too. I thought it was just the UU peeps messing with us. I think it actually looks pretty cool.

UkuEroll
11-29-2011, 02:14 AM
I posted about this some time ago, and was laughed at and told it most be somthing to do with my browser, so I down loaded Chrome and it seemed to fix the problem.

ukuleledaveey
11-29-2011, 02:18 AM
yep it is working fine on chrome for me now aswell, i kinda miss the upside down writing, i may have to flip back to windows explorer now and again for old times sake :)