Hyperlinks not working?

Ziret

Active member
Joined
Aug 7, 2016
Messages
1,610
Points
38
At least on my iPad, hyperlinks are just plain text, so I have to copy and paste into a browser window. Will that be fixed, or am I missing something?
 

Ms Bean

Active member
Joined
Jan 10, 2020
Messages
887
Points
28
Do you have a different device to try hyperlinks? They work fine for me, but I'm not on an iPad.
It could be something in the settings, so I'd check to see if you can check or uncheck something about URLs.
 

Peter Frary

Well-known member
Joined
Feb 21, 2019
Messages
1,063
Points
48
They work fine on my iMac. Don't own an iPad anymore to test but a hyperlink is a hyperlink and should work on any platform. Maybe you need to reboot your iPad? Sometimes that fixes strange stuff.
 

KohanMike

UU VIP
UU VIP
Joined
Sep 15, 2013
Messages
5,651
Points
48
I'm on a Mac Mini 2018 Intel, OS Big Sur 11.5.1, Safari 14.1.2.
 

Kenn2018

UU VIP
UU VIP
Joined
Jun 13, 2018
Messages
3,591
Points
48
Is your information: User Name; Joined Date; Messages; Points, visible before you post a reply? It's totally missing until I push the Post reply green button. Then it shows up in the posted reply. None of the hyperlinks show either.
 

Kenn2018

UU VIP
UU VIP
Joined
Jun 13, 2018
Messages
3,591
Points
48
Well, I see the "Undo" and "Redo" curving arrows in the upper right of the reply text box. (To the left of Toggle BB code.) If I make a mistake in my reply, I can click on the Undo Arrow. But that erases everything in the box and I have to start over.

I can copy all of the text before I use the undo. And then paste it in, but why do all of that? I can just place the cursor and delete the text I don't want.
 

Kenn2018

UU VIP
UU VIP
Joined
Jun 13, 2018
Messages
3,591
Points
48
At least on my iPad, hyperlinks are just plain text, so I have to copy and paste into a browser window. Will that be fixed, or am I missing something?
I don't see any hyperlinks on my posts or anyone else's. I only see: "Like" and "Reply" links on other people's postings. This is the same on my desktop, laptop and iPad devices.
 

Jan D

Well-known member
Joined
Jul 5, 2017
Messages
1,096
Points
48
oops, it's www.kohanmike.com/photography.htm don't have an edit link yet.
Mike, in your message, the URL looks like plain text, but when I touch it, the plain text turns into an underlined hyperlink and the option to open it. So it works like a hyperlink, it just doesn’t look like one. Since I’m using an iPad, I going to try putting your URL in a separate message to see if it looks like a hyperlink in my message, or whether I have the same problem as Ziret. Stay tuned...
 

Jan D

Well-known member
Joined
Jul 5, 2017
Messages
1,096
Points
48
Well, it doesn’t look like a hyperlink, but when I click on the plain text, it works like one. Hmmm....
 

KohanMike

UU VIP
UU VIP
Joined
Sep 15, 2013
Messages
5,651
Points
48
When I see a www. or http: I automatically figure it's a link, even though it might not have an underline.
 

Ziret

Active member
Joined
Aug 7, 2016
Messages
1,610
Points
38
Thanks you guys. I tried again and now it works. I don't know what's changed. I did try touching the link in case it worked even though it's not obviously live, but it didn't work. Then. Or I imagine it's possible I didn't touch it and thought I did? I'll like all these posts so you get trophies.

I just flashed on that time in the stone age when the word hyperlink was exotic and rare and when you used it you had to explain it and then watch people's eyes glaze over and hear them say they'd never have any use for that, thank you very much.
 

Peter Frary

Well-known member
Joined
Feb 21, 2019
Messages
1,063
Points
48
When I see a www. or http: I automatically figure it's a link, even though it might not have an underline.
A lot of web designers disable the underlining for hyperlinks because, well, it's typographically unattractive and smacks of the 1990s. However, they usually make up for it by causing the hyperlink to change color when your mouse passes over it, and blink a different color when activated.
 

KohanMike

UU VIP
UU VIP
Joined
Sep 15, 2013
Messages
5,651
Points
48
A lot of web designers disable the underlining for hyperlinks because, well, it's typographically unattractive and smacks of the 1990s. However, they usually make up for it by causing the hyperlink to change color when your mouse passes over it, and blink a different color when activated.
I just noticed that for me, a link underlines when I mouse over.
 

Kenn2018

UU VIP
UU VIP
Joined
Jun 13, 2018
Messages
3,591
Points
48
The hyperlinks are now working for me.

Still no "Edit" or "Delete" on my replies, but "Report " now shows on posted replies.

I haven't tested the "Attach files" or "Inserting Image" buttons again.