Results 1 to 3 of 3

Thread: Fuji Sprayer Troubles

  1. #1
    Join Date
    Jul 2011
    Location
    central CA
    Posts
    663

    Default Fuji Sprayer Troubles

    I use a Fuji Mini Mite 4 with a T75 G gravity feed sprayer. Last few sessions I'm noticing a drip now and then and build up of lacquer on the cap where the fluid nozzle meets the cap. Lacquer buildup on the diffuser also. I clean the gun after every use and I'm thinking about going back to the original aircap, nozzle and needle which is a 1.3mm. I have the 1.0 installed now. Manual says loosen the packing nut on the nozzle but that hasn't helped.
    Any ideas??

    Edit, the finish is coming out excellent, same as ever
    My Real name is Terry Harris

  2. #2
    Join Date
    Apr 2008
    Location
    Kapolei, Hawaii
    Posts
    1,842

    Default

    Assuming its leaking from the rear of the nozzle (and not the needle/nozzle), use a ratchet and deep socket to tighten the nozzle.

    If you look really good, the mating surface has no gasket - its metal to metal, so you really have to crank on it, without stripping.

    This is the one part of the design I don’t like. Being its the only concession for me, I keep the 1.0 on mine with no issues.

  3. #3
    Join Date
    Jul 2011
    Location
    central CA
    Posts
    663

    Default

    I've tried cranking down on the nozzle with the wrench that comes with the sprayer but it still drips. I'll try with a socket and see. I'm about to order a rebuild kit just to see if that's the problem. The finish is still fabulous but the drips drive me crazy.
    Thanks for the reply!
    My Real name is Terry Harris

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •